Firefox Nightly ไม่ซัพพอร์ท TLS 1.0, 1.1 แล้ว เตรียมเข้าสู่สถานะเลิกใช้งานต้นปีหน้า

2019-09-30

ผู้ผลิตเบราว์เซอร์รายใหญ่ประกาศจะหยุดการรับรอง TLS 1.0, 1.1 ในช่วงต้นปีหน้ามาตั้งแต่ปีที่แล้ว ล่าสุด Firefox เป็นเจ้าแรกที่ออกมายกเลิกการรับรอง TLS 1.0 และ 1.1 ในเวอร์ชัน Nightly เพื่อเตรียมยกเลิกการใช้งานในเวอร์ชันเสถียรต้นปีหน้า

เว็บไซต์ที่ยังใช้งานแค่ TLS 1.0, 1.1 หากเข้าผ่าน Firefox Nightly จะไม่สามารถเปิดได้และขึ้นเป็น “secure connection failed”

TLS 1.0 ออกมาตั้งแต่ปี 1999 ทำให้ปีนี้มีอายุ 20 ปีพอดี ขณะที่โปรโตคอลใหม่ๆ เช่น HTTP/2 นั้นบังคับว่าต้องใช้ TLS 1.2 ขึ้นไป ส่วน TLS 1.3 ก็นิ่งแล้วและมีการใช้งานเพิ่มมากขึ้นเรื่อย ๆ

ที่มา – Bugzilla via GHanks.net

Topics: